Microsoft .NET Framework

Microsoft .NET Framework - это цифровая платформа, позволяющая создавать, корректно запускать и использовать различные приложения или игры, при создании которых, части одного конкретного приложения пишутся разными программными кодами. Эта платформа представляет из себя цифровую среду, в которой разные коды отдельно взятого приложения компилируется в один переходящий код, который в свою очередь понятен самой платформе Framework. Затем переходящий код компилируется в понятный код для непосредственно той операционной системы, под которую разрабатывалось приложение. Например для Windows 7/8/10

Установить данную платформу можно различными способами.

  • Установив операционную систему, пакет обновлений которой уже включает в себя эту платформу.
  • Скачать Net Framework  а затем установить. (Официальные ссылки у нас на сайте)
  • Установить в качестве дополнительного ПО при установке игры.
  • Автоматически установить, используя «Центр обновления Windows»

Бывают случаи: Что во время запуска игры или приложения на экране всплывает окно примерного содержания: «(имя приложения) требует наличие .НЕТ Фреймворк. Пожалуйста скачайте и установите Net Framework 3.5 или выше.» Что делает запуск данного приложения невозможным без этой платформы. Если у вас установлена Microsoft Net Framework 4.7, то это не означает что, вам не нужны более старые версии. Вам понадобится установить и Microsoft Net Framework 4 и предыдущие версии. Настоятельно рекомендуется установить все существующие касательно вашей операционной системы.

 Выберите и установите нужные Вам версии для Windows XP, Vista, 7, 8,10 

Microsoft .NET Framework 1.0

Скачать Microsoft .NET Framework 1.0 для 32/64 бит

Microsoft .NET Framework 1.1

Скачать Microsoft .NET Framework 1.1 для 32/64 бит

Microsoft .NET Framework 2.0

Скачать Microsoft .NET Framework 2.0 для 32 бит

Скачать Microsoft .NET Framework 2.0 для 64 бит

Microsoft .NET Framework 3.0

Скачать Microsoft .NET Framework 3.0 для 32/64 бит

Microsoft .NET Framework 3.5

Скачать Microsoft .NET Framework 3.5 для 32/64 бит

Microsoft .NET Framework 4.0

Скачать Microsoft .NET Framework 4.0 для 32/64 бит

Microsoft .NET Framework 4.5

Скачать Microsoft .NET Framework 4.5 для 32/64 бит

Microsoft .NET Framework 4.5.1

Скачать Microsoft .NET Framework 4.5.1 для 32/64 бит

Microsoft .NET Framework 4.5.2

Скачать Microsoft .NET Framework 4.5.2 для 32/64 бит

Microsoft .NET Framework 4.6

Скачать Microsoft .NET Framework 4.6 для 32/64 бит

Microsoft .NET Framework 4.6.1

Скачать Microsoft .NET Framework 4.6.1 для 32/64 бит

Microsoft .NET Framework 4.6.2

Скачать Microsoft .NET Framework 4.6.2 для 32/64 бит

Microsoft .NET Framework 4.7

Скачать Microsoft .NET Framework 4.7 для 32/64 бит

Microsoft .NET Framework 4.7.1

Скачать Microsoft .NET Framework 4.7.1 для 32/64 бит

Обязательно должна быть установлена версия 3.5, которая включает в себя  более ранние, и версия 4.7.1 (последняя на данный момент)

Будем рады услышать от Вас отзыв, также поможем при установки компонентов, и в исправлении ошибок. Пишите всё в комментариях, чуть ниже

16.11.2020 23:19
Arturs Cernovs
-1
Я 3.5 скачал,установить, а после нее ни одна не устанавливается , тупо просто не запускается установка и все :( ни 4.7 ни 4.7.1
Ответить
16.11.2020 13:14
ваня
0
Цитирую Сергей:
Ребят помогите, вот качаю програму и выскакивает ошибка Framework. И в включении/отключении програмных компонентов у меня нет там ничего. Прошу, помогите!!!

согласен
Ответить
05.11.2020 18:09
Zomm123.NET Framewor
0
Пишет:.NET Framework 4.7.1 или более позднее обновление уже установлены на этом компьютере.Что делать?
Ответить
12.07.2020 14:18
Inkrucio
+4
3.5 c вашего сайта не реагирует , скачал с сайта виндовс, так вот, у меня не отображается ничего. До всех манипуляций у меня был Microsoft .NET Framework 3.5.1, после нового скачивания 3.5 а также 4.7.1, ничего не изменилось. Не появилось новых окон
Ответить
26.05.2020 22:34
Artur
+1
Цитирую жмых:
Получается надо все версии до 3.5 устанавливать

Обязательно должна быть установлена версия 3.5, которая включает в себя более ранние
Ответить
15.04.2020 00:05
Сергей
-1
Ребят помогите, вот качаю програму и выскакивает ошибка Framework. И в включении/отключении програмных компонентов у меня нет там ничего. Прошу, помогите!!!
Ответить
01.03.2020 06:52
Фirgaт
+2
Цитата:
Цитирую Ерлан:

3,5 вообще не реагирует после кнопки "ЗАПУСТИТЬ" , как бы ничего и не было, а 4.7.1 также не идет под эту ОС"

Это делается через Панель управления\Программы и компоненты\включение/отключение компонентов Windows. Там посмотрите, стоят ли галочки напротив нужных вам версий.
Цитата:
Цитирую Ерлан:

3,5 вообще не реагирует после кнопки "ЗАПУСТИТЬ" , как бы ничего и не было, а 4.7.1 также не идет под эту ОС"

Это делается через Панель управления\Программы и компоненты\включение/отключение компонентов Windows. Там посмотрите, стоят ли галочки напротив нужных вам версий.
У меня там затемненная,т.е. частично включён.Как быть,хотел установить,пишет виндус заблокировал,не удаётся завершит установку.
Ответить
17.01.2020 21:48
Админ (Сергей)
-3
Цитирую mc.den:
Здравствуйте! У меня винда 8.1 3.5 поставился а другие нет, пишет, что нужно какое-то обновление чтобы было для этой установки. Что делать? Подскажите пожалуйста.

Вам бы обновиться... Зайдите в центр обновление Виндовс, и обновите всё полностью - т.е саму ОС
Ответить
17.01.2020 10:27
mc.den
+3
Здравствуйте! У меня винда 8.1 3.5 поставился а другие нет, пишет, что нужно какое-то обновление чтобы было для этой установки. Что делать? Подскажите пожалуйста.
Ответить
29.11.2019 12:11
xander
0
у меня win8.1 не могу установить cc++2015
Ответить
02.11.2019 05:06
Админ (Сергей)
+3
Цитирую Виталий:
установлен .NET Framework 4, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1 и 4.6.2. а 4.7 вот что пишет
Блокирующие требования:
.NET Framework 4.7 не поддерживается этой операционной системой.

А какая у Вас ОС?
Ответить
30.10.2019 14:24
Виталий
+5
установлен .NET Framework 4, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1 и 4.6.2. а 4.7 вот что пишет

Блокирующие требования:

.NET Framework 4.7 не поддерживается этой операционной системой.
Ответить
28.10.2019 17:35
Макс
+1
Цитирую Юрий:
папки 2.0 и 3.0 не открываются

Что за папки?
Ответить
23.10.2019 01:27
Юрий
+2
папки 2.0 и 3.0 не открываются
Ответить
05.06.2019 01:43
жмых
-5
Получается надо все версии до 3.5 устанавливать
Ответить
11.02.2019 08:27
Админ (Сергей)
+7
Цитирую Денис:
"Для установки или настройки Microsoft.NET Framework 2.0 SP2 необходимо использовать параметр "Включение или отключение компонентов Windows" в панели управления" --- Что с этим делать? В меню тока 3.5, ставлю там обе галочки не помогает, а 2.0 там нету и он не устанавливается(

Установить старые версии - всегда проблема. Обычно помогает установка с самых первых, ибо поставить их на вверх не получить, будет написано об этом при установке
Ответить
10.02.2019 14:16
Денис
-2
"Для установки или настройки Microsoft.NET Framework 2.0 SP2 необходимо использовать параметр "Включение или отключение компонентов Windows" в панели управления" --- Что с этим делать? В меню тока 3.5, ставлю там обе галочки не помогает, а 2.0 там нету и он не устанавливается(
Ответить
17.12.2018 08:17
Админ (Сергей)
+4
Цитирую Ерлан:

3,5 вообще не реагирует после кнопки "ЗАПУСТИТЬ" , как бы ничего и не было, а 4.7.1 также не идет под эту ОС"

Это делается через Панель управления\Программы и компоненты\включение/отключение компонентов Windows. Там посмотрите, стоят ли галочки напротив нужных вам версий.
Ответить
16.12.2018 19:52
Ерлан
+4
Цитирую Ерлан:
Здравствуйте! Может и мне поможете, проблемка такая: библиотека за 17 год не ставится, пишет, ей нужен NET FRAMEWORK 4.6, устанавливаю НЕТ фраме 4.6.1, пишет, установится не может, т.к не поддерживается этой ОС (ВИНДОВС 7 максимальная)

"Вроде здесь dlltop.ru/soft/135-microsoft-net-framework в комментариях обсуждали.
3,5 вообще не реагирует после кнопки "ЗАПУСТИТЬ" , как бы ничего и не было, а 4.7.1 также не идет под эту ОС"
Ответить
03.11.2018 02:35
Михайло
+1
Цитирую Alexey:
При попытке установить пишет .NET Framework 4.7.1 не поддерживается этой операционной системой.
Windows 8. видимо не 8.1

Стоит Win7sp1 32; Uninstall Tool в установленных показывает версию 4.7.2 с апдейтом (КВ4087364)
Ставил по порядку с самой первой, снеся все раннее стоявшие
Спасибо за статью)
Ответить

Добавить комментарий